# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<w:d([^\[]+)\\/>/<w:ind w:left='.eval("return "."720*$1;").' w:right=""\/>/gm;t' <<< "<w:d2/>"