import Foundation
let pattern = #"<w:d([^\[]+)\/>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"<w:d2/>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<w:ind w:left='.eval("return "."720*$1;").' w:right=""/>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)