// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<w:d([^\[]+)\/>").unwrap();
let string = "<w:d2/>";
let substitution = "<w:ind w:left='.eval(\"return \".\"720*$1;\").' w:right=\"\"/>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}