const regex = /<w:d([^\[]+)\/>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<w:d([^\\[]+)\\\/>', 'gm')
const str = `<w:d2/>`;
const subst = `<w:ind w:left='.eval("return "."720*$1;").' w:right=""/>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);