re = /<w:d([^\[]+)\/>/m
str = '<w:d2/>'
subst = '<w:ind w:left=\'.eval("return "."720*$1;").\' w:right=""/>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result