use strict;
my $str = '<w:d2/>';
my $regex = qr/<w:d([^\[]+)\/>/mp;
my $subst = '<w:ind w:left=\'.eval("return "."720*$1;").\' w:right=""/>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";