using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<w:d([^\[]+)\/>";
string substitution = @"<w:ind w:left='.eval(""return "".""720*$1;"").' w:right=""/>";
string input = @"<w:d2/>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}