# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?m)^[\d]+.+\R//gu;t' <<< "1576
01:14:04,440 --> 01:14:05,780
what's optimal daily allowance means. Which is good for 100 reasons.
1577
01:14:06,380 --> 01:14:09,970
That it's got to be much stronger than the RDA the recommended"