#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?u)(?m)^[\d]+.+\R"
Local $sString = "1576" & @CRLF & _
"01:14:04,440 --> 01:14:05,780" & @CRLF & _
"what's optimal daily allowance means. Which is good for 100 reasons." & @CRLF & _
"" & @CRLF & _
"1577" & @CRLF & _
"01:14:06,380 --> 01:14:09,970" & @CRLF & _
"That it's got to be much stronger than the RDA the recommended"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)