using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)^[\d]+.+\R";
string substitution = @"";
string input = @"1576
01:14:04,440 --> 01:14:05,780
what's optimal daily allowance means. Which is good for 100 reasons.
1577
01:14:06,380 --> 01:14:09,970
That it's got to be much stronger than the RDA the recommended";
RegexOptions options = RegexOptions.CultureInvariant;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}