import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)^[\\d]+.+\\R";
final String string = "1576\n"
+ "01:14:04,440 --> 01:14:05,780\n"
+ "what's optimal daily allowance means. Which is good for 100 reasons.\n\n"
+ "1577\n"
+ "01:14:06,380 --> 01:14:09,970\n"
+ "That it's got to be much stronger than the RDA the recommended";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}