const regex = /(?m)^[\d]+.+\R/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?m)^[\\d]+.+\\R', 'gu')
const str = `1576
01:14:04,440 --> 01:14:05,780
what's optimal daily allowance means. Which is good for 100 reasons.
1577
01:14:06,380 --> 01:14:09,970
That it's got to be much stronger than the RDA the recommended`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);