# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=NitroCams_)(\d+)(-\d+-)(\d+)/$3$2$1/;t' <<< "какоетоимя_NitroCams_11-07-2021_03-44-00-proxy.ts"