import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=NitroCams_)(\\d+)(-\\d+-)(\\d+)";
final String string = "какоетоимя_NitroCams_11-07-2021_03-44-00-proxy.ts";
final String subst = "$3$2$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}