import Foundation
let pattern = #"(?<=NitroCams_)(\d+)(-\d+-)(\d+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"какоетоимя_NitroCams_11-07-2021_03-44-00-proxy.ts"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$3$2$1"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}