const regex = /(?<=NitroCams_)(\d+)(-\d+-)(\d+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=NitroCams_)(\\d+)(-\\d+-)(\\d+)', '')
const str = `какоетоимя_NitroCams_11-07-2021_03-44-00-proxy.ts`;
const subst = `$3$2$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);