using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=NitroCams_)(\d+)(-\d+-)(\d+)";
string substitution = @"$3$2$1";
string input = @"какоетоимя_NitroCams_11-07-2021_03-44-00-proxy.ts";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}