import re
regex = re.compile(r"(?<=NitroCams_)(\d+)(-\d+-)(\d+)")
test_str = "какоетоимя_NitroCams_11-07-2021_03-44-00-proxy.ts"
subst = "$3$2$1"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)