$re = '/(?<=NitroCams_)(\d+)(-\d+-)(\d+)/';
$str = 'какоетоимя_NitroCams_11-07-2021_03-44-00-proxy.ts';
$subst = "$3$2$1";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;