use strict;
my $str = 'какоетоимя_NitroCams_11-07-2021_03-44-00-proxy.ts';
my $regex = qr/(?<=NitroCams_)(\d+)(-\d+-)(\d+)/p;
my $subst = '$3$2$1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";