# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\. | mL |x //g;t' <<< "1x 3.5 mL SST. 1x 4.0 mL gray cap cryovial."