import re
regex = re.compile(r"\. | mL |x ")
test_str = "1x 3.5 mL SST. 1x 4.0 mL gray cap cryovial."
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)