using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\. | mL |x ";
string substitution = @"";
string input = @"1x 3.5 mL SST. 1x 4.0 mL gray cap cryovial.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}