$re = '/\. | mL |x /';
$str = '1x 3.5 mL SST. 1x 4.0 mL gray cap cryovial.';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;