use strict;
my $str = '1x 3.5 mL SST. 1x 4.0 mL gray cap cryovial.';
my $regex = qr/\. | mL |x /p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";