const regex = /\. | mL |x /g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\. | mL |x ', 'g')
const str = `1x 3.5 mL SST. 1x 4.0 mL gray cap cryovial.`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);