#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([A-Z]+)(\d{5}|\d{2}[A-Z]{3})(\d+)([A-Z]+)"
Local $sString = "BANKNIFTY2330935500PE" & @CRLF & _
"FINNIFTY2330618050PE" & @CRLF & _
"NIFTY23DEC21000CE" & @CRLF & _
"TCS23MAR3000PE"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")