import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Z]+)(\\d{5}|\\d{2}[A-Z]{3})(\\d+)([A-Z]+)";
final String string = "BANKNIFTY2330935500PE\n"
+ "FINNIFTY2330618050PE\n"
+ "NIFTY23DEC21000CE\n"
+ "TCS23MAR3000PE";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}