using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-Z]+)(\d{5}|\d{2}[A-Z]{3})(\d+)([A-Z]+)";
string input = @"BANKNIFTY2330935500PE
FINNIFTY2330618050PE
NIFTY23DEC21000CE
TCS23MAR3000PE";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}