const regex = /([A-Z]+)(\d{5}|\d{2}[A-Z]{3})(\d+)([A-Z]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([A-Z]+)(\\d{5}|\\d{2}[A-Z]{3})(\\d+)([A-Z]+)', 'gm')
const str = `BANKNIFTY2330935500PE
FINNIFTY2330618050PE
NIFTY23DEC21000CE
TCS23MAR3000PE`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}