$re = '/([A-Z]+)(\d{5}|\d{2}[A-Z]{3})(\d+)([A-Z]+)/m';
$str = 'BANKNIFTY2330935500PE
FINNIFTY2330618050PE
NIFTY23DEC21000CE
TCS23MAR3000PE';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);