// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([A-Z]+)(\d{5}|\d{2}[A-Z]{3})(\d+)([A-Z]+)").unwrap();
let string = "BANKNIFTY2330935500PE
FINNIFTY2330618050PE
NIFTY23DEC21000CE
TCS23MAR3000PE";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}