import re
regex = re.compile(r"([A-Z]+)(\d{5}|\d{2}[A-Z]{3})(\d+)([A-Z]+)", flags=re.MULTILINE)
test_str = ("BANKNIFTY2330935500PE\n"
"FINNIFTY2330618050PE\n"
"NIFTY23DEC21000CE\n"
"TCS23MAR3000PE")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")