re = /([A-Z]+)(\d{5}|\d{2}[A-Z]{3})(\d+)([A-Z]+)/m
str = 'BANKNIFTY2330935500PE
FINNIFTY2330618050PE
NIFTY23DEC21000CE
TCS23MAR3000PE'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end