package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([A-Z]+)(\d{5}|\d{2}[A-Z]{3})(\d+)([A-Z]+)`)
var str = `BANKNIFTY2330935500PE
FINNIFTY2330618050PE
NIFTY23DEC21000CE
TCS23MAR3000PE`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}