# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(@(\w+))/<a href='\/users\/$2'>$1<\/a>/g;t' <<< "Как заменить отметки/теги (#tag или @user_name) на ссылки с помощью Regex?
К примеру, есть текст поста, в котором есть отметки (@username, @user_login) или теги (#tag, #second_tag).
Нужно их заменять на html-ссылки:
@user_login на @user_login)."