re = /(@(\w+))/
str = 'Как заменить отметки/теги (#tag или @user_name) на ссылки с помощью Regex?
К примеру, есть текст поста, в котором есть отметки (@username, @user_login) или теги (#tag, #second_tag).
Нужно их заменять на html-ссылки:
@user_login на @user_login).'
subst = '<a href=\'/users/$2\'>$1</a>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result