import Foundation
let pattern = #"(@(\w+))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
Как заменить отметки/теги (#tag или @user_name) на ссылки с помощью Regex?
К примеру, есть текст поста, в котором есть отметки (@username, @user_login) или теги (#tag, #second_tag).
Нужно их заменять на html-ссылки:
@user_login на @user_login).
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<a href='/users/$2'>$1</a>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)