// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(@(\w+))").unwrap();
let string = "Как заменить отметки/теги (#tag или @user_name) на ссылки с помощью Regex?
К примеру, есть текст поста, в котором есть отметки (@username, @user_login) или теги (#tag, #second_tag).
Нужно их заменять на html-ссылки:
@user_login на @user_login).";
let substitution = "<a href='/users/$2'>$1</a>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}