const regex = /(@(\w+))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(@(\\w+))', 'g')
const str = `Как заменить отметки/теги (#tag или @user_name) на ссылки с помощью Regex?
К примеру, есть текст поста, в котором есть отметки (@username, @user_login) или теги (#tag, #second_tag).
Нужно их заменять на html-ссылки:
@user_login на @user_login).`;
const subst = `<a href='/users/$2'>$1</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);