using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(@(\w+))";
string substitution = @"<a href='/users/$2'>$1</a>";
string input = @"Как заменить отметки/теги (#tag или @user_name) на ссылки с помощью Regex?
К примеру, есть текст поста, в котором есть отметки (@username, @user_login) или теги (#tag, #second_tag).
Нужно их заменять на html-ссылки:
@user_login на @user_login).";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}