#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(@(\w+))"
Local $sString = "Как заменить отметки/теги (#tag или @user_name) на ссылки с помощью Regex?" & @CRLF & _
"К примеру, есть текст поста, в котором есть отметки (@username, @user_login) или теги (#tag, #second_tag)." & @CRLF & _
"Нужно их заменять на html-ссылки:" & @CRLF & _
"@user_login на @user_login)."
Local $sSubst = "<a href='/users/$2'>$1</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)