import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(@(\\w+))";
final String string = "Как заменить отметки/теги (#tag или @user_name) на ссылки с помощью Regex?\n"
+ "К примеру, есть текст поста, в котором есть отметки (@username, @user_login) или теги (#tag, #second_tag).\n"
+ "Нужно их заменять на html-ссылки:\n"
+ "@user_login на @user_login).";
final String subst = "<a href='/users/$2'>$1</a>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}