# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*[\\/\\]([^\\/\\]+)[\\/\\]index\.js$|.*[\\/\\](.*)/$1$2/gm;t' <<< "c:\Users\victor\Documents\index.js
c:\Users\victor\Documents\some.js"