#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m).*[\/\\]([^\/\\]+)[\/\\]index\.js$|.*[\/\\](.*)"
Local $sString = "c:\Users\victor\Documents\index.js" & @CRLF & _
"c:\Users\victor\Documents\some.js"
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)