package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*[\/\\]([^\/\\]+)[\/\\]index\.js$|.*[\/\\](.*)`)
var str = `c:\Users\victor\Documents\index.js
c:\Users\victor\Documents\some.js`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}