$re = '/.*[\/\\\\]([^\/\\\\]+)[\/\\\\]index\.js$|.*[\/\\\\](.*)/m';
$str = 'c:\\Users\\victor\\Documents\\index.js
c:\\Users\\victor\\Documents\\some.js';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;