const regex = /.*[\/\\]([^\/\\]+)[\/\\]index\.js$|.*[\/\\](.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*[\\\/\\\\]([^\\\/\\\\]+)[\\\/\\\\]index\\.js$|.*[\\\/\\\\](.*)', 'gm')
const str = `c:\\Users\\victor\\Documents\\index.js
c:\\Users\\victor\\Documents\\some.js`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);