using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*[\/\\]([^\/\\]+)[\/\\]index\.js$|.*[\/\\](.*)";
string substitution = @"$1$2";
string input = @"c:\Users\victor\Documents\index.js
c:\Users\victor\Documents\some.js";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}