use strict;
my $str = 'c:\\Users\\victor\\Documents\\index.js
c:\\Users\\victor\\Documents\\some.js';
my $regex = qr/.*[\/\\]([^\/\\]+)[\/\\]index\.js$|.*[\/\\](.*)/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";